Problem with a Greek Subtitle

What's on your mind. Discussion.
Forum rules
Under no circumstances is spamming or advertising of any kind allowed. Do not post any abusive, obscene, vulgar, slanderous, hateful, threatening, sexually-orientated or any other material that may violate others security. Profanity or any kind of insolent behavior to other members (regardless of rank) will not be tolerated. Remember, what you don’t find offensive can be offensive to other members. Please treat each other with the kind of reverence you’d expect from other members.
Failure to comply with any of the above will result in users being banned without notice. If any further details are needed, contact: “The team” using the link at the bottom of the forum page. Thank you.
valtsit
Posts: 2
Joined: Wed Jan 03, 2007 7:57 pm

Problem with a Greek Subtitle

Postby valtsit » Wed Jan 03, 2007 8:08 pm

Hallo to everybody,

i have downloaded i greek subtitle (for the movie Perfume). When i open the file i dont get greek letters but some ieroglifigs. Can somebody help me? My pc runs on german windows does this create any problem...
Thanks for any help... :o

DoyanGemblong
Posts: 1
Joined: Sun Jan 14, 2007 3:06 am

Postby DoyanGemblong » Sun Jan 14, 2007 3:33 am

You should set your Unicode encoding to ISO 8859-12 or something. I'm sorry I'm not familiar with windows to help you do it. Are you sure the sub is Greeks? Sometimes someone uploads a wrong sub.

Nikephoros
Posts: 35
Joined: Sun Jan 14, 2007 5:11 pm

Postby Nikephoros » Sun Jan 14, 2007 5:36 pm

First download the Videolan player.

Then install and run Videolan.

Go to File>Open File>

At the "Open" field browse until you have the movie selected. Below it will say "Use Subtitle"
Then where it says "File" browse until you select the subtitle file.

Further, you have to click on the [Advanced Settings] which will bring up a menu that looks like this:

Image

This is where you have to select the ISO-8859-7 encoding which is above MacGreek so you cannot miss it. Then click "OK".

Click"OK" again and it should work fine.

If anyone knows how to use Videolan with Greek subtitles without having to select ISO-8859-7 every time let me know. Because it really pisses me off.

Worst

Postby Worst » Mon Jan 15, 2007 12:36 am

I was trying to set hebrew by default in VLC... and I can't find it too.

Maybe it will be easiest to use another player like BS player, where you can simply set Greek by default in subtitle properities.

Nikephoros
Posts: 35
Joined: Sun Jan 14, 2007 5:11 pm

Postby Nikephoros » Mon Jan 15, 2007 8:35 am

Go to >Settings>Preferences>

This will bring up a new menu. Click where it says: "Input/Codecs"

You will see a field that says: "Subtitle Language"
When you hover over that text input you are told:
"Language of the subtitle track you want to use(comma seperated, two or three letter country code)"

Image

But the thing is I do not know what to put in that box. I tried EL for ELLINKA, GR, ELL and none of them save me from manually having to select the Greek codepage when I select the subtitle.

As for BSplayer I will check it out someday since the fact it has a media library and playlists makes it very attractive. But I am conservative when installing software I do not want too much crap installed on my pc.

Worst

Postby Worst » Tue Jan 16, 2007 1:45 pm

Thanx for response. For me it's not working too... Maybe it's time to read the VLC documentation.

I am conservative when installing software I do not want too much crap installed on my pc.


I agree with you. VLC is the best player cus it plays everything and you can set anything on your mind... but it's really not "user friendly" and it's very very difficult to use. in that case using BS player for every day movie watching makes your life much more easier, don't you think??

Nikephoros
Posts: 35
Joined: Sun Jan 14, 2007 5:11 pm

Postby Nikephoros » Fri Jan 26, 2007 6:36 pm

Someone in the Videolan forum told me the following which worked:

Preferences -> Input / Codecs -> Other codecs -> Subtitles under "Subtitles text encoding" then press Save and close the player.

valtsa
Posts: 1
Joined: Mon Feb 12, 2007 8:06 am

Postby valtsa » Mon Feb 12, 2007 8:07 am

Nikephoros wrote:Someone in the Videolan forum told me the following which worked:

Preferences -> Input / Codecs -> Other codecs -> Subtitles under "Subtitles text encoding" then press Save and close the player.


THis works for the VLC player! Thank you so much!

TZOTZIOY
Subtitles Admin
Posts: 25
Joined: Mon Dec 18, 2006 10:26 am
Location: Athens (the original one)
Contact:

Postby TZOTZIOY » Wed Mar 14, 2007 2:48 am

Nikephore wrote:If anyone knows how to use Videolan with Greek subtitles without having to select ISO-8859-7 every time let me know. Because it really pisses me off.

UTF-8 encoded subtitles, if understood by vlc (and it should), will make your life easier. You won't have to go to advanced settings and other similar stuff.
--
Just an earthbound misfit, I.

Nikephoros
Posts: 35
Joined: Sun Jan 14, 2007 5:11 pm

Postby Nikephoros » Wed Mar 14, 2007 4:04 pm

The question is not so simple. Because do hardware player support UTF-8?

TZOTZIOY
Subtitles Admin
Posts: 25
Joined: Mon Dec 18, 2006 10:26 am
Location: Athens (the original one)
Contact:

Hardware players and UTF-8

Postby TZOTZIOY » Wed Mar 14, 2007 9:29 pm

I think no hardware player supports UTF-8, but who cares? You should include your subs in the .avi file and create a .divx. That's what divxmux and the older fuse.exe exist for.

Typically you will use a GUI frontend (AviSub comes to mind first, and it's Hellenic :) ) for the sub-multiplexing procedure.
--

Just an earthbound misfit, I.

solfranz
Posts: 4
Joined: Thu Jul 31, 2008 8:58 am

SUPER DVD CREATOR

Postby solfranz » Thu Jul 31, 2008 10:06 am

SUPER DVD CREATOR can make and burn the movie,
with ISO-8859-7

luli123
Posts: 1
Joined: Wed Sep 01, 2010 5:55 am

Re: Problem with a Greek Subtitle

Postby luli123 » Wed Sep 01, 2010 7:40 am

Nu pot decat sa-ti urez facturi MARI...

photiscon
Posts: 1
Joined: Fri Sep 07, 2012 5:50 pm

Re: Problem with a Greek Subtitle

Postby photiscon » Fri Sep 07, 2012 5:52 pm

in bs player you go to preferences->subtitles->font->change the SCRIPT to greek

User avatar
SmallBrother
Site Admin
Posts: 949
Joined: Sun Mar 04, 2012 12:59 pm
Location: Somewhere on this globe

Re: Problem with a Greek Subtitle

Postby SmallBrother » Fri Sep 14, 2012 4:14 pm

In VLC player there are (I have) TWO possibilities for displaying greek: ISO-8859-7 and Windows-1253. I found that some subs work with one, not with the other. Try both.

Also i have come across greek subs which were useless regardless that setting, text was always displayed as a bunch of weird characters, or just a line of questionmarks. In that case, I just gave up.

Anyway, VLC must be closed and re-opened before a change of the decoding setting takes effect.


Return to “Off-topic talk”

Who is online

Users browsing this forum: No registered users and 0 guests